AMD RX580's - The best ROI Card - IMHO


All this talk of hashrates has got me wanting to tweak all my rigs again.

I think I’m gonna strip them all down and rebuild them into shelving. They’re all open-air chassis right now and I keep thinking a nice shelf-based arrangement might be nicer, and if needed I can wheel it into a grow tent :slight_smile:

If I do, I may make videos of the move as I never made any videos while building all the rigs in the first place.


I’m just curious if you guys still think the RX580 is the best ROI card? I’m looking at building my first rig, and trying to decide which direction to go with it. The RX580 does still seem like it is a great card when I look at I’m just wondering if it’s the one I should go for.

Also, one other thing I have wondered about is how much priority you guys put on trying to get the same brand of cards. I’m sure it is much easier when they are all the same brand of card so there are less drivers, but it seems like it could be hard to actually line up that many cards at once as they go out of stock so quickly and many places only allow you to buy one card per customer. Are you guys just buying whatever’s available and making it work, or waiting it out to be the same brands of cards for each rig?

Thanks in advance for the help! :beers:


Hi JesseC
I think ROI is really dependent on the price you get the GPUs for, what you want to mine and which coins you think will go up. Resale value of the GPUs as gaming cards just in case the mining market should go toes up is also a consideration for me. Before the GTX 1070 went up in price it was a consideration for me.
It is much easier to use nvidia than AMD so it depends how much time you want to invest.
There are plenty of RX 580’s back on the shelves in my area now (New Zealand) so they may be back in your area soon but the price is still a little high $430 USD
Everything is compared to eth these days so I figured being the most popular was a good enough reason to target it so I just went with the crowd. :sheep::sheep::sheep:
There are rumors of eth becoming not POW (proof of work) soon in which case I don’t know what would happen.
After finding this thread and editing my eth.bat file I am really liking the extra control I have over the RX 580 now :smiley:

Have you used gpedit to disable windows updates through the group policy editor? Assuming you have that in your version of windows. I feel for ya mate

@Tryptoned My second gpu in my above post is exactly that gpu running at 31.22 Mh/s. -ewal 0x03BEF224EAf3b41c18DAE95282a611879cf9c77d/munternet -mode 1 -etha 0 -cclock 1210 -cvddc 850 -mclock 2120 -mvddc 880 -tt 60 -fanmin 24 -platform 1 -eres 3 -tstop 80 -tstart 50


I have disabled my windows updated but last night my windows had updated and resetted my everything. how is it even possible. i had 30.5 mh on every gpus. now they are back to 19 mh even when I am still having AMD blockchain driver. wtf.
6 x AMD RX 580 Sapphire Pulse 8gb Samsung memory

edit: disabled windows updates again. then changed my drivers to compute mode again (I guess windows update changed it to graphics) now everything is back to normal.


Switch to SMOS if you have a dedicated rig it will be the best decision you will make.

I moved from windows to it and its awesome.


How can I check this one out? I have 6 x RX 580 8gb sapphire pulse (samsung memory).


Could you please share your bat file for ETH mining. RX 580 8gb saphhire pulse samsung memory. I used AMD to overclock and getting 30.5 MH. not sure how to deal with the voltage thingy. do you mind sharing your setting for your rx 580?


Hi guys, i have a little problem. Maybe you can help me.
I am Tieko from Italy, addicted to technologies and
crypto-fan. Here if you speak of crypto currencies the
only things you obtain are large eyes and “what?” :slight_smile:
After reading Pigsfoot post about Rx580’s minings power
i have done the rig.
5 Rx580 Gigabyte Aorus 8GB
4 Rx560 Gigabyte Aorus 4GB
2 Cooler Master 1000V and a third for spare.
It was very difficult to obtain hardware but
But , after bios flashing and configuration,
my hashrate does not takeoff. All the parameters are equal to
the example showed , Memory clock, Gpu clock, everything…
but claymore mines at the same speed.
The only difference i have found is the PCIe field showed
that in your Asrock seems to be 12 Pcie 2.0 x 1 and in my board are 19 1.0 x1
I have the mainboard ASUS b250
mining expert and not the Asrock h110. Can you read the specs
and tell me if this is the problem? i have everything equal to
your example but the mining speed is the original one.
So i am sad, thinking that in the same time i mine more slowly
than possible.
Thanks in advance and sorry for my bad English, it was 10 years
i didn’t use it. :slight_smile:
It’s important, here in italy we pay the electricity 3 times than you.


Hey @Tieko

congratulazioni per entrare nel settore minerario, può essere gratificante ma a volte molto frustrante

The two main things which make the most difference are drivers and BIOS Updates.

You mention you have BIOS updated the cards which is great, what GPU driver are you using? I have had issues with the latest blockchain driver so would suggest using a slightly older one, from memory i think my rigs use 17.11.xx. You can even use the beta blockchain driver as that works well.

If you are already using a blockchain drivers make sure you have set the cards to “compute” mode and not the default graphics setting.

Any other settings should be regarded as “tweeking”… updating the BIOS using the correct driver and setting it to compute will be the main things needs to speed up the cards.

in bocca al lupo :+1:


Thanks for your prompt reply. :slight_smile: Also in italian :slight_smile:
Driver downloaded and installed without problems. But in Radeon Settings there is not (believe me) the “compute mode”. ahahahah I followed AMD instructions (it is not so hard) but no “Gpu workload” to change. Now i am investigating. Thanks a lot. Really. When done i will build a second rig and i will post some other “toys” to mine :slight_smile:


Update : the problem is that on the site there is only the lates driver. Not 17.11.xx - there is a way to obtain it?
(free food furniture if you came in italy ). I need to re-size the rig. Rx560 and Rx580 cards must not reside toghether. If i use optimal values for Rx580, are not suitable for 560. If there is a way to have the older driver i must be in debt for the life.


Guys, this is the driver i use 17.11.1. It is the full download version so will not update unless you click on “the get latest version” option.

Its listed on the AMD driver site via the right hand menu under - Download Previous Drivers & Software

Before you install it remove the current version and reboot the computer

Once installed and all cards are detected properly open the AMD Radeon Settings, click on the Gaming Tab, top left and click on Global settings. Each card will be listed at the top. On the left of all the setting is a button called “GPU Workload”, it will be set to gaming by default. Click this and set it to Compute. Do the same for all cards on your Rigs.

** Check this isn’t on your current driver before you go through all this **

I would also recommend resetting the WattMann settings on every card as you now have a different driver.

When finished reboot and start up Claymore again. You should now at a pretty good Mhs rate.

Good luck. Cheers… Pigsfoot :pig::footprints:


Good morning from Italy!!! :slight_smile:
Thanks a lot for the link, it was very very useful also if i already founded it. Why ? Now i will explain.
I have downloaded from AMD the 17.11.4 version that seemed to me older. I was wrong. To see my beloved “Compute mode” field i need the 17.11.1 , it’s the life. Pigsfoot just tell me where and i will send you my gifts. If you came in Italy you’re my guest. No doubt. But … :slight_smile:
But…(there is always a but…) the war is not over. The Rig hangs and show me the pretty old beloved blu screen. So I divided the rig into 3 differents mini-rigs. 3 Pc , 3 different mainboards, 3 of all. When the first one will be perfect i will replicate it. Until then i will use the 3 differents installations to make calculations.

Here you are my situation. If i launch Claymore the system hangs. If i launch other miners (that does not send setting for power/gpu i think) everything works well. Win10 fresh install, Drivers 17.11.1 - compute mode activated - bios updated… Wattman…uhm… here i nedd again your help. Wattman has lots of settings, and i tried to modify them. But here hangs. Can you help me? Only one warning. Pay attention to the Pci information showed. Is it normal?


Step by step is my second name. :slight_smile:
But i am a little unlucky sometimes.


Have you used DDU to uninstall the existing driver and Pixel Clock Patcher?

Maybe get one gpu working properly first before adding any more.
Then once you have done one plug them in one at a time with a reboot to ensure it’s not a power issue.
You can stagger the boot time in claymore’s .bat file if need be.


Thank you. Yes i have used it…

I just solved the mistery. Everything was correct. This night i have measured shares and other values.
The problem was the pool !!! I was using coinotron… same settings with ethermine… double speed…
The rig with default bios, default driver, default everything… 27/28… before with all the customizations… 18…
Arrghhhh :scream:
The Pool is important , more important than expected.

I want to thanks everyone for the precious help. Now i will test all for a couple of weeks in default mode, after in “racing” mode.


Fantastic :smiley: I’m glad you got it sorted.
Nanopool is also worth a try if you get too many stale shares on ethermine.


Thank you very much. I was not sure if it was my fault or pool fault. Today , with a little “tweak” we are running near 200/201 Mh/S, i am very glad. Now the next trouble is “how to avoid power expenses” , i am engaged with local technician of solar power, wind power, hydrogen generator. Analyzing every possible source of power low cost. The office is a good idea, but i don’t want to loose the work for ethereum :slight_smile:


And now… the final question: i am mounting a set of fan for additional cooling. For your experience is better operate them veicolating fresh air to the back of cards… or to “suck” the air from the back of the cards?
Thanks in advance for your reply.


I’m not super experienced but mine blows air in. Running 59c at 25-35% fan speed.