GPU's Won't turn on =( Help, please!

The OS has been acting weird for a month or so, my mining soft has crashed before nothing out of the normal though, maybe bad OC or instability (mainly on equihash with EWBF miner)…

But yesterday something else happened… every single miner I tried failed, with different algos even with LyraRe2 which never failed to me not even once(til now)

I tried mining Mona,Zec,Zen, Verge all on different pools with brand new drivers installed and stock settings (no OC) …and nothing
Every time a miner crashed vga’s would cease being recognized by whether Msi afterburner or the driver itself and I would have to restart the system.

After trying lots of settings and mining soft I left the rig mining Verge on Lyra and went to sleep. When I woke up today I saw the system up and but the vga’s turned off (the monitor is plugged to the mainboard’s on-board video). I restarted the pc like 3 times and nothing happened…

I couldn’t try anything else because I had to come to work but my Idea is to unplug everything and try the cards on my personal pc without the risers…the fact that they don’t even turn on worries me a little :confused:

My setting:

3 x Gigabyte gtx 1080 gaming G1
Psu: EVGA Supernova G2 1000 watts 80 plus gold
Mobo: MSI but forgot the model, I will update this info when I get home
Win 10 pro x64
SSD: Kingston 120 gb
Ram: 8 gb
Virtual memory: set to 16 Gb

Thanks a lot guys! :slight_smile:

2 Likes

My initial thought is that you are having a problem with the risers. It’s going to be somewhat of a process to figure out what is going on.

The 3 GPUs you have plugged in, are all your risers powered by 1 sata power cable or do you have no more than 2 risers plugged in per sata power cable.

Pictures help.

Have you made any adjustments to your motherboard BIOS?

Let us know what the motherboard type is. I’ve had 2 MSI motherboards that are not good for mining and had to replace them.

How long has your rig been running? Any problems in the early stages?

2 Likes

I keep seeing risers as the culprit all over the place. Probably worth it to buy 3 times as many as you need just to do a complete swap for a quick debug check.

2 Likes

lol I think this is a bit much typically I only order a few extra. Have only had 2 dead out of the 20 or so I am using.

As I do not like windows for mining might I suggest downloading SMOS to a thumb drive and see if it has problems. If this works it eliminates any hardware issues and would narrow your troubleshooting down if it doesn’t work then you know its hardware and can proceed with @ImaginaryPi’s direction. It typically only takes a couple of minutes to download SMOS and etch the thumb drive.

Just a suggestion to cut your possible troubleshooting variables in half. I

2 Likes

I think you’re right about the risers, see one day I found out that even without plugging the psu to vga power cable, the vga could turn on fed by just the riser (Riser fed by psu, vga plugged to riser’s pcie port)…then I found out that some considerable deal of power passes through a riser.

Second issue, yes…only one sata with 5 outputs feed the risers… which leads me to think of a possible answer to why can’t I make the vga’s work at 65 % TDP and why did they crash so often when I was mining equihash?

I haven’t made any change to bios at all and yeap…I too have a MSI mobo and from the beginning I found it a bit too hard to cope with. My gaming machine has a msi mobo and it was completely different and way more user friendly than the rig’s one.
It was difficult to install win10 as it wouldn’t recognize the bootable usb on ‘‘windows 10 compatibility mode’’ and wouldn’t allow me to install win 10 if that compatibility option was unchecked…I don’t remember how I solved that.

My rig has been running from September the 16th of 2017 til yesterday with no major issues, just those miner’s crashes and minor setbacks with OC config. I also found out that one of the three gpu’s cant be Oced at all, but now I see the problem it’s the third time I read about not plugging all the risers with one cable and it never even occured to me to do it otherwise.

I’m still at work, I will gladly update info and upload pics as soon as I get home

@SukoshiHidariMaki Thanks a lot for the tip :slight_smile: , I actually am waiting for the arrival of 2 more vga’s and a pack of 6 brand new risers

@Nekko to be honest I kind of don’t like win for anyhting at all haha xD, I use it to mine because I’m not savvy enough on Gnu and linux and even though I use it it’s way easier for me to swap algos and configurate my vga’s on win. I will try SMOS and let you know about it!
Thank you! =)

Thanks a lot guys!! I hope I can get those cards to work again

4 Likes

This isn’t necessary until you add the 4th GPU.

I am also not familiar with GNU or Linux but SMOS was plug and play. It required only for me to set my overclocks, but worked straight out of the gate. Learning to type the start command for the miners in the Rig Group section took a bit of trial and error but I was pretty unfamiliar with making my own batch file when i first did this as I used the BBT multi miner which edited the and ran the miners for me. I never ran an individual miner hehe.

1 Like

Thanks buddy :slight_smile:
I will download it and try it as it seems pretty interesting! Plus as you say it’s a easy way to test the system outside of the OS which by the way I will have to reinstall now that we mention it.

1 Like

Hey guys!!

I’ve got some updates!

All of the VGA’s work perfectly well, you were all right, it’s the risers.
On the one hand the cards turn on without them and it’s the mobo the one that determines whether to deliver power to a device or not, and as the risers were faulty the mobo was taking it as if it had been nothing plugged to the pcie ports.

On the other hand, are the risers broken? I don’t think so, it’s gotta be that greasy dirt that dripped from the vga’s to them trough the connector and blocked the contacts preventing them to connect to the cards in question. A bit of propyl alcohol a brush and compressed air will get the job done.
What I do wonder is why is that greasy stuff like oil dripping down from the cards. My assumption is that constant heat and their vertical position is causing the thermal paste to leak in that oilish form. I better keep an eye for the temps, which are good so far.
I will let you know when I clean all of the risers, clean-install windows and get everything back and running :slight_smile:

P.S.: There’s also some sulfur on the back of the little card that connect the riser port to the main board…weird.








2 Likes

That greasy dirt stuff doesn’t look like it belongs. I’ve not seen anything that even looks close to that on our rigs. Are you sure something didn’t drip on the rig? Maybe you were leaning over the rig while eating a hamburger or something.

I’m glad you have found the problem. I hope everything goes smoothly to get it operational again.

2 Likes

Hey Imaginary Pi!

Sorry I took so long to reply…I myself spent a week offline, been a little ill :confused:
I’ve recovered now, so I’m back on track.

I dedicated the past couple of days to clean all that greasy stuff off of the cards and risers and my package arrived here in the process so I have 6 brand new risers now.
I made all of the risers work and tested the cards one by one and they worked.

When I assembled all of them on the rig, one of them failed :angry: … so I cleared mos and isntalled them one by one. Now all of them turn on but I got ‘‘can’t intialiaze nvml’’. Then I DDU’d the drivers and almost fell asleep after that, so today’s task is reinstall the driver and see if it works, if it doesn’t then I will have to clean install windows.

Now I have a challenge, I have the other 2 vga on my personal pc (also mining when not in use…which is like 98% of the time) and have to install the fury x that was there, on a rig with other 3 1080. Now I know it is possible, but my rig acts weird and some times I see the fact it works as a miracle lol… When I install the radeon driver msi afterburner doesn’t recognize it even though it works.

can a 1000 watt 80 plus gold evga psu deal with those 4?

Another thing I just can’t get to achieve is running the vga’s at 65% TDP…even my brand new 1080 FTW2 hybrid will crash if set to 65% tdp…could you?

Oh by the way, I have a MSI H270 PC Mate… supposedly capable of mining as described on their website.
And I’m in a small basement, with just wood above, and I don’t eat down there, I only drink mate (argentinian drink) if I spill it bye bye rig haha,

Thanks a lot for your help once again! =)

1 Like

Lots of things to address here. I’ll try to catch them all.

This is, more than likely, caused because the GPU isn’t getting enough power on bootup. You will need to go into your BIOS and turn off unnecessary items such as HD Audio, LED Lights, and other things that you aren’t going to be using.

Yes, that should be enough with proper power settings.

We don’t have any 1080’s. The power settings we have on the cards aren’t set that low either. Don’t beat yourself up if you can’t get 65% to work. Set it to whatever will work. Every GPU is different, even if it came from the same manufacturer. The assembly of the GPU could be just a little off and not allow you to achieve what others are getting. Also, sometimes there is a different manufacturer of the chip itself but packaged as the same product.

2 Likes

Yes, sorry laying it all together at once…too many questions I know

Thanks for all the tips!! See I read a lot all the time and eventually attempt to achieve
it all as close to what I read as possible, it’s then when I hit the wall… e.g.: the 65% thing.

The nvml error is printed out on EWBF when I try to start mining, even though I could be a boot up thing?
Still I will proceed to turn off all the things I won’t use just like you said.

Thanks again!

1 Like

NVML is a Nvidia driver issue. Be sure you have the latest drivers installed. After using DDU, install the GPUs back 1 or 2 at a time. Not all at once. Sometimes putting them all back in at the same time will stall out the computer when it tries to load all the drivers back.

1 Like

Yeah I just reinstalled it, but never removed the other two…so it must be that.
I will DDU the driver again and proceed to installing them one at a time.

What I don’t understand is why all of these is happening…the cards were working perfectly well until one day it all began failing, out of the blue.
This problem started before I chose to remove and clean the risers…

First this and then the vga’s turned off (that’s when I opened this thread a week or so ago)

Here are some pics of how they behave now (I still haven’t ddu’d them and installed them one by one)

This is CUDA device 1, it throws NVLM error but still works, slower than it should as you can see.

This are 0 and 1 together, 0 works fine.

This is how Afterburner sees CUDA device 2, this happens after I attempt to run the miner.
The device won’t be recognized again until I reset the pc.

Sorry they are regular pics and kind of blurry, I had mt wife sent them to me as I’m at work.

1 Like

Update:

I did a fresh OS install as the system was kind of…say faulty. Removed 2 of the videocards and left just 1 plugged to the main pci-e port through a riser

After all of the updates and installation processes, I installed VS 2013 Redistributable as it was missing and throwing a .dll error when trying to run EWBF.

The system installed the nvidia drivers automatically so I went on and tried opening EWBF again, and the result was the same as before… miner starts, screen flickers and then throws error 33 or 43 (on the miner), subsequently the vga coolers start running at 100% speed and MSI afterburner stops recognizing the devices just like in the last picture above.

I just don’t know what else can I do :pensive:

I’ll try to swap the riser for another one, check if the riser power feed is plugged correctly and ultimately try plugging the VGA straight to the pcie port of my gaming pc and see if it can handle a stress test and / or any game with heavy graphics. But I doubt this is a faulty VGA mainly because the same error happened to me but made all the three video cards fail alike, and the other two work just ‘‘Fine’’ (They mined a whole day yesterday)

1 Like

I still believe this is a driver issue. You say that it installed the drivers automatically. I don’t think it did. If it did, it didn’t install them properly. Use DDU and clear the drivers again. Use GeForce Experience program to install the latest drivers.

When testing it out, try without opening MSI Afterburner. Just run is stock until you know it’s working properly.

As to the “Why?”, there are a number of different possibilities. Update failed, windows defender deleted something, windows hates you, etc…

1 Like

Have you tried just downloading SMOS and using it to determine if it is a hardware or software issue?

1 Like

Never thought of using GeForce experience to install the drivers.
I’ll do that then, what I also thought is about using another Sata to psu power feed cable, so if DDUing the current win-installed driver and reinstalling through GF experience doesn’t work I will proceed to replacing the cable.

I think that’s the cable I was using when it all happened, and now that I think of it all the three gpu were connected to the same cable until I read that it’s better to have separate sata power feed cables for each riser.

Honestly, it’s gotta be that…

@Nekko haven’t yet, mainly because I found out I had hardware related problems before(whe I saw the risers were all dirty and not connecting properly), but I will donwload it now. it’s a good idea to have an extra usb stick with that OS.

2 Likes

It just clears up the difference between hardware and software.

1 Like

Hey guys!!

So it took me some time. After an intense tug-of-war with the rig, reinstalling the OS, plugging-unplugging testing, resetting and trying again… I found out where the problem really was. As I said before it is NOT recommended to plug multiple risers to the same sata power cable… but I didn’t know that…until now.

See, this is what happens :

Port melted

And I thought…’‘Okay cool, then it’s because the psu plug stopped working, I will put some tape on it and go on, maybe I can still use this cable’’ => Because I thought the cable was damaged and then after trying different cables on that port I came to the conclusion it was just the port (before actually taking a thorough look)

Well good thing I did doubt about the cable being damaged too and took a closer look prior to deciding to keep using it :

The funny part is that the cable does plug and work but…no thanks.

By the way thanks a lot @Nekko =D! The OS you recommended helped me strengthen my conviction about the problem being hardware related as it failed as soon as I tried it.
Awesome tool, I will keep it close in case of future issues :slight_smile:

@ImaginaryPi Thanks a lot for all your support, after all of the described above the problem persisted…drivers were the last issue to deal with. I proceeded doing it all as smooth and clean as you told me too but the last step was to go to Device Manager and click on the two vga that were not recognized (one of them was) and click on update driver. That alone wouold link the connected cards to the installed driver…

…in the end, windows is a b**ch haha :stuck_out_tongue:

One mire time,

Thanks a lot guys!!

3 Likes

💰 YEN · YouTube ·️ YEN.CAMP 🧠