Ledger Nano S + Iconex troubles

ledger
icon
ledgernanos
ledger-nano-s

#1

I am trying to get my Leder Nano S to work with the Iconex Chrome Extenstion, but I only get a screen to select a Wallet Address. I dont get the “Portal” page which is schown in the Iconex PDF instructions.

Here is what I tried so far.

  • the ledger + iconex on two different computers
  • uninstalled/re-installed iconex chrome extension
  • uninstalled/re-installed the Icon App from ledger
  • tried Chrome 68.0.3440.106 and Chromium 63.0.3239.108
  • Ledger Nano S - FW 1.4.2
  • Icon App 1.0.2

Here is the screen that shows up when I connect with my ledger.

If I hit the X at the top right corner the Wallet Address page vanishes and I am back to the initial home page with the 3 options (Create Wallet, Load Wallet, Connect to Ledger)

This is the screen I would expect to see according to the PDF instructions

Any help appreciated. Thanks!


#2

That’s the only screen I get when I connect my ledger. I believe that 2nd picture is only for wallets you created that’s not a ledger.


#3

That’s what it’s supposed to look like. It defaults to 5 “hx” addresses. pick one > copy address > paste > transfer. Not the most intuitive, but it’s quick (almost instant) and it works.


#4

Thanks @naytreeee and @airbaker! :clap:t3:

I was really concerned I was doing something wrong. I was reading thru the “Guide to use Ledger Wallet on ICONex” like 10 times and I had expected a little bit more than this simplistic “Wallet Address” transfer interface.