Miner DOWN! Please help! (Driver issue, Fixed)

Today randomly I noticed my miner is down…

Im getting “No AMD OPENCL or NVIDIA CUDA GPUs found, exit”

I didnt change anything, it was running just fine last night, and today its no longer up… Im curious as to what happened.

Anyone help me out?

RX570 Red devils (4 currently, I have 6 but 2 awaiting power cable)

Asrock Pro Btc H81 board

Update:

I tried cleaning the drivers with DDU and re-installing but when I went to re-install new drivers it told me windows has detected it currently has the best driver…

its as if the DDU didnt do anything

1 Like

On face value some things to check

  1. Power Supply - Is it able to support that many cards?
  2. Were the devices overheating ?
  3. Check the risers - Some ‘melt’ and have poor QA standards
  4. You say it detects the cards - Perhaps its a driver related issue? I know modded AMD cards played funny with various drivers (in the past), however that may have changed.

Perhaps some else can chime in here ie @ImaginaryPi

2 Likes

It detects the cards, but the devices are down (Code 43)
I think its automatically installing drivers after I wipe its driver… Cant seem to figure out how to stop it from doing that

1 Like

Yeah nothing seems to get too hot. It was running just fine, I checked the driver log and it looks like it was getting updates or receiving some kind of update.

1 Like
  1. Disable windows updates first
  2. What version of AMD drivers are you running?
2 Likes

Try these drivers

http://support.amd.com/en-us/kb-articles/Pages/Radeon-Software-Crimson-ReLive-Edition-Beta-for-Blockchain-Compute-Release-Notes.aspx

2 Likes

Im gonna run DDU another time… Hopefully that works, thanks for the help, please stick around if you can… Freaked out that this happened seemingly randomly

1 Like

The FIX was:

be sure to disable windows update

run DDU in safe mode to remove old driver

Install new driver from amd (posted above by Entropy)

I think somehow windows updated the driver and in doing so disabled the rig.

Running 6+ cards on windows 10? this video may help

3 Likes

I’m glad you found the fix but let me add this.

  • Disable the automatic Windows update
  • Make sure miner and drivers are cleared by Windows Defender (I believe that is how you may have lost your OPENCL file. It’s happened to me)
  • When you install the AMD drivers, be sure you click the box to disable automatic driver updates.

I found with AMD driver installation software and UI, it does not allow you to disable automatic driver update after installation.

Also, using device manager to check the to see if the GPU drivers are up to date doesn’t work. It will always tell you that you are using the most current drivers.

On a side note: I’m on here most of the day while working. I left to go get lunch and your system goes down. smh

3 Likes

💰 YEN · YouTube ·️ YEN.CAMP 🧠