Miner Error: cannot find block data


Hi guys,

So I finally got my first rig setup and decided to test out mining on one GPU. I downloaded and setup Claymore CryptoNote AMD GPU Miner v10.2 to test out mining some good 'ol Monero. Unfortunately, I’m getting the following error accepting shares:

cannot find block data:
cannot convert blob data

This is my very first attempt at GPU mining, so please advise what I can do to resolve this. Thanks!


does this help?


Thanks. I tried that earlier before posting and it said something about not recognising the command. I’ll see if I can replicate and post it here…


Make sure you are using the new Cryptonight7 algorithm, if you are using the old one, unpredictable results may arise.

Stay Fishy.


So I decided to switch to Ethereum instead and got positive results:

I’m actually loving the hashrate as its stock! So no need to mod the bios. I also installed Trixx and was able to get the temperature down to 60-61 by increasing the fan speed to 50% rather than auto.


Thanks, please advise what I need to add and where I need to add it. If you need further info, please let me know.


All good, the software you might like to try is xmr-stak:

Grab the one for your platform and when choosing to mine Monero, be sure to select “monero7” as the algorithm changed about a month ago. Also make sure the pool you are using has also updated, I noticed some pools havn’t updated yet.

Stay Fishy


Thanks, I’ll give it a go later. What’s a good pool that you can recommend?


For mining pools, I prefer the larger ones like: https://miningpoolhub.com/

However, I know other people prefer smaller pools for the chance of larger rewards.

It’s a preference thing really, as mining is like a lottery.

Stay Fishy


So that was the problem right there folks. I was using a pre-cryptonightv7 miner. Hence why it didn’t recognise the “-pow7” command. I’m now using v11.3 and everything works fine:

I don’t like the hash rate that I’m getting as I believe it should be around 860mhs. But I do like the overall temperatures I’m getting on this. Any advice on if I can use a command to increase the hash rate?

So far I’ve been successful on ETH, ETC and now XMR. This is my first time and I can say I’m learning fast and having fun! Thanks guys for your input.


Mining Pool Hub if you need auto switching capability
Suprnova Pools if you want to get the most blocks


I am having the same problem with xmr as you did earlier. I am on ethos 1.3.1 using claymore-xmr v11.3. I have tried absolutely everything with my local.config file and I am still getting cannot convert blob data. I am sharing my most recent show miner page as well as my local.conf file, if anyone has any suggestions they would be much appreciated. The wallet address/worker name with e-mail info is not correct, I kept the same format just changed it in order to make this post. Thank you for your help.